Using the search box

markm Feb 14, 2020

  1. markm

    markm TrainBoard Supporter

    795
    232
    20
    I've been trying to use the "Search..." in the page header for some months. Every search I attempt returns:

    The search could not be completed. Please try again later.

    Is this search actually working? Is there another seacrh method I should be using?

    Mark
     
  2. bremner

    bremner Staff Member

    6,006
    5,054
    104
    So....there is a weird bug....when the site sees heavy usage, it doesn't work, when I can try to diagnose it without impacting the site, it works...
     
  3. markm

    markm TrainBoard Supporter

    795
    232
    20
    SO it sounds like the best time to use it is around 3:00AM ?
     
  4. bremner

    bremner Staff Member

    6,006
    5,054
    104
    Not that late...but yes
     
  5. BoxcabE50

    BoxcabE50 HOn30 & N Scales Staff Member TrainBoard Supporter

    63,481
    10,479
    652
    Please keep in mind that we did not write the software. So there may limits as to what we can do to resolve an issue. Sometimes a bug makes itself obvious, other times it is a sneaky pest causing all of us headaches. John has spent considerable time trying to catch this varmint. We are not happy that it is causing folks trouble. Please bear with us.
     
  6. markm

    markm TrainBoard Supporter

    795
    232
    20
    I realize the limits for debugging someone else's software, but at this point I've tried to use search over a 5 day period (2/13-2/18), weekdays, over the weekend, during the day, night and at 1:00AM and before this sporadically for months. It seems to be very consistent at this point. Good luck on debugging it.

    Mark
     
  7. Doorgunnerjgs

    Doorgunnerjgs TrainBoard Member

    598
    881
    21
    Not working tonight, 7:45 pm, CST.
     
  8. BoxcabE50

    BoxcabE50 HOn30 & N Scales Staff Member TrainBoard Supporter

    63,481
    10,479
    652
    We are still seeking a remedy. :(
     
  9. bremner

    bremner Staff Member

    6,006
    5,054
    104
    I have increased the max_input_vars....so far so good
     
    Doorgunnerjgs likes this.
  10. markm

    markm TrainBoard Supporter

    795
    232
    20
    Looks like all my searches are working. Congrats!
     
    Doorgunnerjgs likes this.
  11. bremner

    bremner Staff Member

    6,006
    5,054
    104
    l honestly just took a wild guess while at work last night....I.E. 3:00am and everything that I could do was done, and playing with a server is work related.
     
    RBrodzinsky likes this.
  12. markm

    markm TrainBoard Supporter

    795
    232
    20
    I worked in Silicon Valley for 25 years and the most important thing I learned was to NEVER underestimate the power of dumb luck.
     
    Pastor John likes this.
  13. bremner

    bremner Staff Member

    6,006
    5,054
    104
    agreed
     
  14. Carl Sowell

    Carl Sowell TrainBoard Supporter

    2,599
    4,516
    75
    Search not working today ? ? ?
     
  15. RBrodzinsky

    RBrodzinsky Staff Member TrainBoard Supporter

    5,627
    2,646
    96
    Certainly looks that way! Oh, John (@bremner )!
     
  16. bremner

    bremner Staff Member

    6,006
    5,054
    104
    rebooted
     
    Hardcoaler likes this.
  17. Hardcoaler

    Hardcoaler TrainBoard Member

    6,754
    20,020
    104
    Search function is out of service. Can someone take a look? Thank you.
     

Share This Page