Using the search box

markm Feb 14, 2020

  1. markm

    markm TrainBoard Supporter

    772
    206
    19
    I've been trying to use the "Search..." in the page header for some months. Every search I attempt returns:

    The search could not be completed. Please try again later.

    Is this search actually working? Is there another seacrh method I should be using?

    Mark
     
  2. bremner

    bremner Staff Member

    5,670
    4,091
    97
    So....there is a weird bug....when the site sees heavy usage, it doesn't work, when I can try to diagnose it without impacting the site, it works...
     
  3. markm

    markm TrainBoard Supporter

    772
    206
    19
    SO it sounds like the best time to use it is around 3:00AM ?
     
  4. bremner

    bremner Staff Member

    5,670
    4,091
    97
    Not that late...but yes
     
  5. BoxcabE50

    BoxcabE50 Staff Member TrainBoard Supporter

    60,832
    5,618
    651
    Please keep in mind that we did not write the software. So there may limits as to what we can do to resolve an issue. Sometimes a bug makes itself obvious, other times it is a sneaky pest causing all of us headaches. John has spent considerable time trying to catch this varmint. We are not happy that it is causing folks trouble. Please bear with us.
     
  6. markm

    markm TrainBoard Supporter

    772
    206
    19
    I realize the limits for debugging someone else's software, but at this point I've tried to use search over a 5 day period (2/13-2/18), weekdays, over the weekend, during the day, night and at 1:00AM and before this sporadically for months. It seems to be very consistent at this point. Good luck on debugging it.

    Mark
     
  7. Doorgunnerjgs

    Doorgunnerjgs TrainBoard Member

    497
    587
    12
    Not working tonight, 7:45 pm, CST.
     
  8. BoxcabE50

    BoxcabE50 Staff Member TrainBoard Supporter

    60,832
    5,618
    651
    We are still seeking a remedy. :(
     
  9. bremner

    bremner Staff Member

    5,670
    4,091
    97
    I have increased the max_input_vars....so far so good
     
    Doorgunnerjgs likes this.
  10. markm

    markm TrainBoard Supporter

    772
    206
    19
    Looks like all my searches are working. Congrats!
     
    Doorgunnerjgs likes this.
  11. bremner

    bremner Staff Member

    5,670
    4,091
    97
    l honestly just took a wild guess while at work last night....I.E. 3:00am and everything that I could do was done, and playing with a server is work related.
     
    RBrodzinsky likes this.
  12. markm

    markm TrainBoard Supporter

    772
    206
    19
    I worked in Silicon Valley for 25 years and the most important thing I learned was to NEVER underestimate the power of dumb luck.
     
  13. bremner

    bremner Staff Member

    5,670
    4,091
    97
    agreed
     
  14. Carl Sowell

    Carl Sowell TrainBoard Supporter

    2,282
    2,365
    62
    Search not working today ? ? ?
     
  15. RBrodzinsky

    RBrodzinsky Staff Member TrainBoard Supporter

    5,297
    1,926
    83
    Certainly looks that way! Oh, John (@bremner )!
     
  16. bremner

    bremner Staff Member

    5,670
    4,091
    97
    rebooted
     
    Hardcoaler likes this.

Share This Page