SwitchWithIt Ver 1.7.8.8 (Important)

ncng Aug 5, 2020

  1. ncng

    ncng TrainBoard Member

    648
    29
    28
    I have uploaded a new version to SourceForge that corrects a serious problem that was found in the version I posted on Sunday. Here is a link to the corrected version:

    https://sourceforge.net/projects/switchwithit/

    I apologize for having releases so close together.

    David
     
  2. Doorgunnerjgs

    Doorgunnerjgs TrainBoard Member

    523
    647
    18
    Just downloaded it and can't get past the default items. I add a reporting mark of NP, enter a date of 01/01/1955, Layout name of "NP and CRIP Interchange", but won't let me pick NP as the Home Route ID. When I select "Save Default Items", it says, "A valid Home Road ID has not been selected"
     
  3. ncng

    ncng TrainBoard Member

    648
    29
    28
    John,
    The key here is "selected". The defaults section does not allow for the entry of "NP". The "NP" must be selected not entered. Go up to the top of the default page and Add "NP" in to the list of Reporting Marks. Then go down and select it in the defaults. I will update the program with this information when I post a new version in a little while.

    David
     
  4. Doorgunnerjgs

    Doorgunnerjgs TrainBoard Member

    523
    647
    18
    I did add both NP and CRIP for reporting marks above. Went to Home Road and drop down shows nothing, so couldn't "select".
     
  5. Doorgunnerjgs

    Doorgunnerjgs TrainBoard Member

    523
    647
    18
    Screen grabs. First after entering Reporting Marks.
    upload_2020-9-6_16-53-34.png

    Then attempting Default Items.

    upload_2020-9-6_16-54-47.png
     
  6. ncng

    ncng TrainBoard Member

    648
    29
    28
    Interesting. I just tried it on my computer and it works as advertised. I will install the program on a new computer tomorrow and see if I have the same problem.

    NOTE: I rarely check the forum except when I have uploaded a new version. If you select the Help section it lists my contact information on the first page. The contact address is SwitchWithIt@zoho.com. If you post here, you may not get a response for a month or more.

    David
     
  7. ncng

    ncng TrainBoard Member

    648
    29
    28
    I installed the program on a new computer. I added SP to car marks. I then went down to the defaults area and selected the Home Road ID drop down combo box. SP showed up.

    If you go to the Rolling Stock Tab and select the Car Marks drop down combo box, do the 2 entries you made show up?

    If they do, go back to the Miscellaneous Tab and see if they are also present in the Defaults area?

    I don't know what is happening with your installation. If the problem persists, I would suggest you uninstall the program and then install it again.

    David
     
  8. Doorgunnerjgs

    Doorgunnerjgs TrainBoard Member

    523
    647
    18
    Found the problem, when C:/Users/user/SwitchWithIt was created during installation, security was set to read only!!!!! Using Properties->Security was able to change to allow create/modify!

    Hope this helps others!
     
  9. ncng

    ncng TrainBoard Member

    648
    29
    28
    John,

    Thanks for letting me know. The installation program doesn't change anything on the computer other than extract the required files and put a shortcut on the desktop, if selected. This must be something Microsoft has done for security reasons. I will make a note about it and see if I can find the source of the problem.

    David
     
    Doorgunnerjgs likes this.

Share This Page