Road Number problems with a Bachmann GP7...

Sumner Oct 8, 2019

  1. Sumner

    Sumner TrainBoard Member

    115
    61
    4
    I just bought a new Bachmann GP7 with a UP road number of 116. It ran fine using the default 03 address. I change it to 116 and it doesn't respond. Change it to 0116 and still doesn't respond. I can program in any 4 digit number and it responds.

    I have other engines with Digitrax decoders that I'm using 3 digit numbers, such as 951 on a Kato E9. They all run fine. Is my problem due to the stock Bachmann decoder that comes with the GP7?

    For the time being I'm using 1160 and it works but would like to use 116 to match the number on the loco.

    Any Ideas? Thanks,

    Sumner
     
  2. gatrhumpy

    gatrhumpy TrainBoard Member

    694
    83
    15
    It's the way your DCC system is trying to address that three digit number.
     
  3. Sumner

    Sumner TrainBoard Member

    115
    61
    4
    I'm kind of new to this and don't really under stand the response. Could you clarify a little? I'm using DCC++ and JMRI.

    Having problems figuring out why I can put the same 3 digit number into a Kato engine with a Digitrax decoder and it works fine but can't do it with the Bachmann and its factory decoder.

    Thanks for any additional help,

    Sumner
     
  4. DCESharkman

    DCESharkman TrainBoard Member

    3,609
    519
    53
    It is most likely caused by the decoder being set in the wrong addressing mode. There is the two-byte address mode that goes from 1 - 127, and the 4 byte address mode that goes from 128 to as high as your system goes. The reason why it works at 1160 is because it is in 4 byte addressing mode.

    To change this you need to modify CV29 to use the lower addressing addresses.
     
  5. wvgca

    wvgca TrainBoard Member

    169
    50
    14
    by that argument it shouldn't work with address 3 either ?? it's below 128 ?? other than that, i have no idea, i use a mrc prodigy, and it takes low [1 0r 2 digit] numbers as well as high [4 digit] numbers ??
     
  6. Sumner

    Sumner TrainBoard Member

    115
    61
    4
    Thank you, thank you, thank you, that did it. Changed CV29 to 3 and the road address to 116 and it works perfect.

    Sumner
     
    Last edited: Oct 9, 2019 at 7:00 PM
  7. gatrhumpy

    gatrhumpy TrainBoard Member

    694
    83
    15

Share This Page