Maybe an old question...

ardsuppi Dec 11, 2020

  1. ardsuppi

    ardsuppi TrainBoard Member

    33
    8
    2
    Hi all.

    As title says, it is maybe an old question. I'm experiencing a strange behavior of DCC++

    While testing and regulating current sensors for next implementation on my layout, I discovered that locos having F0 (directional lights) switched ON, when disconnected and reconnected to tracks, they loose the F0 state (so lights are switched OFF), while the software (rocrail in my case) still shows F0 ON. I have to toggle OFF/ON lights to have them ON again.

    That behavior doesn't happen with commercial controllers, in which when lights are ON, they resume their state everytime the loco is connected to track.

    Do I have to change anything in DCC++ code? I will check also with DCC++EX. Regarding DCC++EX, can I still use rocrail DCC++ command station features to drive a DCC++EX one?

    Thanks for suggestions.
     
  2. schufti

    schufti TrainBoard Member

    24
    2
    2
    This may well be a problem of the old DCC++ code.
    The new DCC++EX does repeat the msgs as long as the Arduino is not powered off or reset.
    So the headlights come on even if the track is powered down/up via <0><1>
    be aware: Dis-/reconnecting the serial does reset the Arduino ...

    p.s.: I too use DCC++EX with rockrail.
     
  3. ardsuppi

    ardsuppi TrainBoard Member

    33
    8
    2

    Thank you very much schufti!
    in few days I will download the last DCC++EX code and test tracks and sensors. Will write a report for sure.
     

Share This Page