Lionel Crossing Issue - Need advice

Matt Bradley Dec 27, 2018

  1. Matt Bradley

    Matt Bradley TrainBoard Member

    59
    0
    12
    Hey gang! Long time lurker, first time I've posted in the O Scale Forum. I've been in N scale for years and decided to buy some O scale just to have on the shelf in my office. Then I decided I wanted to run them a little. Then I set up tables... and now I'm waiting on the UPS guy to bring me more! Anyway, I'm not here to talk about my sickness. (y)

    I just bought my first accessory, a Lionel crossing with flasher (no gates).

    DSC_1906 resize.jpg

    Out of the box it does not flash. It either lights up one side or both at the same time and stays that way. It only lights up when the train hits the sensor (the track) and shuts off after the train passes. Bell works fine too. Should I send it back or is there an easy fix?
     
  2. acptulsa

    acptulsa TrainBoard Member

    2,377
    1,955
    51
    I'd send it back. Especially at Lionel prices.
     
  3. BoxcabE50

    BoxcabE50 HOn30 & N Scales Staff Member TrainBoard Supporter

    63,028
    9,430
    652
    I would return it.
     
  4. country joe

    country joe TrainBoard Member

    432
    349
    18
    Welcome to the wonderful world of O Gauge.

    I would recomend returning the crossing since it's brand new.
     
  5. Keith

    Keith TrainBoard Supporter

    4,439
    1,475
    74
    Have the same crossing. However, not sure what went wrong.....
    One set of flashers ones not work! Can plug it into either plug, with
    no flash! The other set works just fine! Hoping I can just send in the
    non working signal, rather than the entire crossing!
     
  6. Matt Bradley

    Matt Bradley TrainBoard Member

    59
    0
    12
    I contacted Lionel via email when I first posted this. Have not heard from them so will call them after the 1st. If no go, I'll send it back where I bought it.
     

Share This Page