electrical switch issue

ScaleyGuy Jan 21, 2020

  1. ScaleyGuy

    ScaleyGuy New Member

    4
    3
    1
    My layout is based on DC with electrical blocks. I have been using Atlas electrical controllers with sporadic results. Sometimes they work exactly as I planned and other times, it seems that there is what's best described as an electrical bleed off. I can shut off a block and it's still somehow getting power. Another time the switch will work exactly as it should. Any thoughts from anyone?
     
  2. dalebaker

    dalebaker TrainBoard Member

    1,194
    945
    27
    I would look to see if you are feeding the block through turnouts. Many are power routing. With a turnout thrown the right way, you could still be powering the block.

    good luck!
     
    Doug Gosha, RGW and Joe Lovett like this.
  3. Dennis461

    Dennis461 New Member

    2
    0
    1
    You did not mention the switch part number, that might help others respond.
    I do not use Atlas electrical switchs.

    If a particular block gives you trouble, but another does not...
    Swap the switches around and see if the trouble remains with the original block or moves to the new block.
     
  4. Doug Gosha

    Doug Gosha TrainBoard Member

    1,272
    948
    30
    From personal experience over 50 years or more, I can say it is VERY rare to have an Atlas electrical component fail.

    Doug
     
  5. acptulsa

    acptulsa TrainBoard Member

    1,783
    890
    34
    That center off position isn't so easy to hit with a slide switch. I use toggles and rotary switches.
     

Share This Page