Z central station

husafreak Jul 23, 2019

  1. husafreak

    husafreak TrainBoard Member

    156
    90
    4
    Does anyone have a contact at zcentralstation? A moderator or email contact? I seem to be unable to join. It appears to be a working site...
     
  2. shortpainter

    shortpainter TrainBoard Member

    169
    557
    11
    Same here. I have tried three times to join and it never lets me. I gave up over a year ago.
     
  3. markm

    markm TrainBoard Supporter

    745
    197
    17
    I've pretty much given up on Zcentralstation. My account was apparently disabled several years back. The password recovery didn't work and emails to the moderators either went unanswered or got an auto-responder message than I'm a spam bot and am being ignored.
     
  4. husafreak

    husafreak TrainBoard Member

    156
    90
    4
    Thanks, I had no luck earlier this year but then saw it advertised in Z Track magazine and I see relatively new posts there so I thought I’d try again, no luck though.
     
  5. rvn2001

    rvn2001 TrainBoard Member

    257
    102
    15
  6. husafreak

    husafreak TrainBoard Member

    156
    90
    4
  7. Kurt Moose

    Kurt Moose TrainBoard Member

    5,305
    2,646
    93
    Yeah, I haven't been on there for a number of years either.(n)
     
  8. rvn2001

    rvn2001 TrainBoard Member

    257
    102
    15
    The site was recently updated.
     
  9. LWR21

    LWR21 TrainBoard Member

    21
    11
    15
    I was on last week and it looked like the domain was hacked and was advertising British Football teams.
     
  10. rvn2001

    rvn2001 TrainBoard Member

    257
    102
    15
    It's working fine now. What you saw was a placeholder for the site .
     
  11. LWR21

    LWR21 TrainBoard Member

    21
    11
    15
    That makes sense. Thanks.
     
  12. stonysmith

    stonysmith New Member

    9
    3
    11
    We had to switch to a new web host server, and it took quite a while to get everything working again. (A few things are still a work in progress)
    There SHOULD be no problems with registrations, but if you encounter any, you can contact John Kellett or myself
    JohnK: soccrdad525@yahoo.com
    Stony: stonysmith@stonysmith.com
     
  13. husafreak

    husafreak TrainBoard Member

    156
    90
    4
    Thanks. I tried to get on but the bot stops me, says there is already a user with my username or email address is already being used or I do not have permission to join. I sent an email to soccrdad. Thanks
     
  14. poppy2201

    poppy2201 TrainBoard Member

    672
    84
    20
    A follow up question, why does it take so long to get an account approved?
     
  15. CNE1899

    CNE1899 TrainBoard Member

    37
    49
    2
    Along with the rest of you, I have had similar problems with ZCentral as well. Glad to know I am not alone. I'll have to give it another try.
     
  16. Commodore

    Commodore TrainBoard Member

    73
    37
    6
  17. husafreak

    husafreak TrainBoard Member

    156
    90
    4
    No response to my emails
     
  18. CNE1899

    CNE1899 TrainBoard Member

    37
    49
    2
    I am waiting for a response email from Z Central.
     
  19. rvn2001

    rvn2001 TrainBoard Member

    257
    102
    15
    Sunday in chat on ZCS John realized that he wasn't getting emails from the site. He's working on resolving this issue .
     
  20. CNE1899

    CNE1899 TrainBoard Member

    37
    49
    2
    Well, I tried to sign up again. The site said my user name was already taken, so I requested a new password. The new password came, but when I went to log in, a message came up saying my account has not been approved.
    I had tried to sign up way back in February.
     

Share This Page