Kato SD70ACe runs but no lights after DCC install

ptolbert May 12, 2022

  1. ptolbert

    ptolbert New Member

    2
    0
    1
    Hi All,

    I've added the DigiTrax DN163K1C to my new Kato SD79ACe. The OEM light board took a bit of effort to remove but the DigiTrax board went in nicely.

    After programming, the Loco sped around the layout nicely, however, the headlights do not engage when turned on. Usually I have the opposite problem and it's motor tab related.

    Where should I check for a solution? I've done a factory reset and nada.
     
  2. MK

    MK TrainBoard Member

    2,881
    2,178
    66
    Hmmm...if you have motor power and have tried resetting the decoder, and F0 still doesn't turn on/off the headlight, I would think it's most likely a bad LED on the decoder. Is it a SMD LED or a discrete LED? If discrete and you are comfortable with soldering you might be able to change it out.

    I would wait and see what other ideas people have but a call to Digitrax might be in order.
     
  3. woodone

    woodone TrainBoard Member

    937
    33
    22
    Well we know it is getting power because you said the loco runs. I guess I would remove the decoder and test the LED.
    YOU could test it in place but you need to know what you are doing!
     
  4. MRLdave

    MRLdave TrainBoard Member

    920
    236
    24
    No lights in either direction? It would need to be 2 bad LEDs for that to happen, which isn't likely (but not impossible). Are you sure the loco took the factory reset? And do other locos work fine (light wise)? From the Digitrax decoder manual
    4.4 “Strange” locomotive light operation If you can’t control the operation of the lights in your locomotive with your throttle (in default 128, or 28 speed step mode), be sure that the decoder is programmed for advanced 28 speed step mode. Your Digitrax decoder was shipped programmed to 128 speed step mode. You may have changed your decoder’s programming when performing the decoder test procedure. In any case, if you are not able to turn the locomotives lights on and off, you will need to change CV29 to 006 or another appropriate value that sets the decoder to advanced 28/128 speed step mode. If you can’t turn the lights on and off or the lights blink when you run the loco, make sure you are not running a standard (14 speed step operation) decoder trying to process 28 speed step Advanced packets. Be sure that the decoder and command station are using the same mode by programming CV29 to an appropriate value or by changing the command station’s operating mode to match the decoder
     
  5. MK

    MK TrainBoard Member

    2,881
    2,178
    66
    Not to be condescending but how did you reset the decoder?
     
  6. Carl Sowell

    Carl Sowell TrainBoard Supporter

    2,693
    5,009
    75
    Well, I have another idea. If it were me, I would not mess with the LED's until I know what has happened.

    1st you mentioned programming and resetting the decoder, but you did not mention how you did those procedures. How did you do that ? If making adjustments by using CV's, that will work but a person is more likely to change one not required to be changed. If you are using JMRI then look at the function mapping window. If not using JMRI, I would highly recommend you check it out. It is a free software program.
     
  7. DCESharkman

    DCESharkman TrainBoard Member

    3,890
    1,035
    60
    You need to also make sure that the locomotive's decoder is not set in consist mode. I some cases if it is not the lead locomotive, the lights are disabled in consist mode.
     
    308GTSi likes this.
  8. ptolbert

    ptolbert New Member

    2
    0
    1
    Thanks for the tips everyone!

    @MRLdave was correct on this, it was 14 step speed causing the issue. After confirming with DigiTrax documentation which had an entry specifically for this, I reprogrammed and all is now well.
     

Share This Page